equal
deleted
inserted
replaced
1 # Copyright 1999-2020 Gentoo Authors |
|
2 # Distributed under the terms of the GNU General Public License v2 |
|
3 |
|
4 EAPI=7 |
|
5 |
|
6 inherit meson |
|
7 |
|
8 DESCRIPTION="xdg-desktop-portal backend for wlroots" |
|
9 HOMEPAGE="https://github.com/emersion/xdg-desktop-portal-wlr" |
|
10 |
|
11 if [[ ${PV} == 9999 ]]; then |
|
12 EGIT_REPO_URI="https://github.com/emersion/${PN}.git" |
|
13 inherit git-r3 |
|
14 else |
|
15 SRC_URI="https://github.com/emersion/${PN}/releases/download/v${PV}/${P}.tar.gz" |
|
16 KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86" |
|
17 fi |
|
18 |
|
19 LICENSE="MIT" |
|
20 SLOT="0/9999" |
|
21 IUSE="elogind systemd" |
|
22 REQUIRED_USE="?? ( elogind systemd )" |
|
23 |
|
24 DEPEND=" |
|
25 >=media-video/pipewire-0.2.9:= |
|
26 dev-libs/wayland |
|
27 >=dev-libs/wayland-protocols-1.14:= |
|
28 elogind? ( >=sys-auth/elogind-237 ) |
|
29 systemd? ( >=sys-apps/systemd-237 ) |
|
30 " |
|
31 RDEPEND=" |
|
32 ${DEPEND} |
|
33 sys-apps/xdg-desktop-portal |
|
34 " |
|
35 BDEPEND=" |
|
36 >=media-video/pipewire-0.2.9:= |
|
37 >=dev-libs/wayland-protocols-1.14 |
|
38 >=dev-util/meson-0.47.0 |
|
39 virtual/pkgconfig |
|
40 " |
|
41 |
|
42 src_configure() { |
|
43 local emesonargs=( |
|
44 "-Dwerror=false" |
|
45 ) |
|
46 if use systemd; then |
|
47 emesonargs+=("-DHAVE_SYSTEMD=1") |
|
48 else |
|
49 emesonargs+=("-DHAVE_ELOGIND=1") |
|
50 fi |
|
51 |
|
52 meson_src_configure |
|
53 } |
|