gui-libs/xdg-desktop-portal-wlr/xdg-desktop-portal-wlr-9999.ebuild
changeset 47 1491f2dcaa8a
parent 46 09afc3bdda54
child 48 783858104dcd
equal deleted inserted replaced
46:09afc3bdda54 47:1491f2dcaa8a
     1 # Copyright 1999-2020 Gentoo Authors
       
     2 # Distributed under the terms of the GNU General Public License v2
       
     3 
       
     4 EAPI=7
       
     5 
       
     6 inherit meson
       
     7 
       
     8 DESCRIPTION="xdg-desktop-portal backend for wlroots"
       
     9 HOMEPAGE="https://github.com/emersion/xdg-desktop-portal-wlr"
       
    10 
       
    11 if [[ ${PV} == 9999 ]]; then
       
    12 	EGIT_REPO_URI="https://github.com/emersion/${PN}.git"
       
    13 	inherit git-r3
       
    14 else
       
    15 	SRC_URI="https://github.com/emersion/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
       
    16 	#KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
       
    17 	KEYWORDS=""
       
    18 fi
       
    19 
       
    20 LICENSE="MIT"
       
    21 SLOT="0/9999"
       
    22 IUSE="elogind systemd"
       
    23 REQUIRED_USE="?? ( elogind systemd )"
       
    24 
       
    25 DEPEND="
       
    26 	>=media-video/pipewire-0.2.9:=
       
    27 	dev-libs/wayland
       
    28 	>=dev-libs/wayland-protocols-1.14:=
       
    29 	elogind? ( >=sys-auth/elogind-237 )
       
    30 	systemd? ( >=sys-apps/systemd-237 )
       
    31 "
       
    32 RDEPEND="
       
    33 	${DEPEND}
       
    34 	sys-apps/xdg-desktop-portal
       
    35 "
       
    36 BDEPEND="
       
    37 	>=media-video/pipewire-0.2.9:=
       
    38 	>=dev-libs/wayland-protocols-1.14
       
    39 	>=dev-util/meson-0.47.0
       
    40 	virtual/pkgconfig
       
    41 "
       
    42 
       
    43 src_configure() {
       
    44 	local emesonargs=(
       
    45 		"-Dwerror=false"
       
    46 	)
       
    47 	if use systemd; then
       
    48 		emesonargs+=("-DHAVE_SYSTEMD=1")
       
    49 	else
       
    50 		emesonargs+=("-DHAVE_ELOGIND=1")
       
    51 	fi
       
    52 
       
    53 	meson_src_configure
       
    54 }