sys-apps/xdg-desktop-portal/xdg-desktop-portal-1.8.0.ebuild
changeset 0 22d142c795ec
equal deleted inserted replaced
-1:000000000000 0:22d142c795ec
       
     1 # Copyright 1999-2020 Gentoo Authors
       
     2 # Distributed under the terms of the GNU General Public License v2
       
     3 
       
     4 EAPI=7
       
     5 
       
     6 inherit autotools systemd
       
     7 
       
     8 DESCRIPTION="Desktop integration portal"
       
     9 HOMEPAGE="https://flatpak.org/ https://github.com/flatpak/xdg-desktop-portal"
       
    10 SRC_URI="https://github.com/flatpak/${PN}/releases/download/${PV}/${P}.tar.xz"
       
    11 
       
    12 LICENSE="LGPL-2.1"
       
    13 SLOT="0"
       
    14 KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
       
    15 IUSE="geolocation screencast"
       
    16 
       
    17 BDEPEND="
       
    18 	dev-util/gdbus-codegen
       
    19 	sys-devel/gettext
       
    20 	virtual/pkgconfig
       
    21 "
       
    22 DEPEND="
       
    23 	dev-libs/glib:2
       
    24 	dev-libs/json-glib
       
    25 	media-libs/fontconfig
       
    26 	sys-fs/fuse:0
       
    27 	geolocation? ( >=app-misc/geoclue-2.5.3:2.0 )
       
    28 	screencast? ( >=media-video/pipewire-0.3:= )
       
    29 "
       
    30 RDEPEND="${DEPEND}
       
    31 	sys-apps/dbus
       
    32 "
       
    33 
       
    34 src_configure() {
       
    35 	local myeconfargs=(
       
    36 		--with-systemduserunitdir="$(systemd_get_userunitdir)"
       
    37 		$(use_enable geolocation geoclue)
       
    38 		$(use_enable screencast pipewire)
       
    39 		--disable-docbook-docs # flatpak not packaged
       
    40 		--disable-libportal # not packaged
       
    41 	)
       
    42 	econf "${myeconfargs[@]}"
       
    43 }