dev-qt/qtdbus/qtdbus-5.15.2-r1.ebuild
changeset 6 34fc7a87c4eb
equal deleted inserted replaced
5:bb9bed9cdc04 6:34fc7a87c4eb
       
     1 # Copyright 1999-2021 Gentoo Authors
       
     2 # Distributed under the terms of the GNU General Public License v2
       
     3 
       
     4 EAPI=7
       
     5 QT5_MODULE="qtbase"
       
     6 inherit qt5-build
       
     7 
       
     8 DESCRIPTION="Qt5 module for inter-process communication over the D-Bus protocol"
       
     9 
       
    10 if [[ ${QT5_BUILD_TYPE} == release ]]; then
       
    11 	KEYWORDS="amd64 arm arm64 ~hppa ppc ppc64 ~sparc x86"
       
    12 fi
       
    13 
       
    14 IUSE=""
       
    15 
       
    16 DEPEND="
       
    17 	~dev-qt/qtcore-${PV}:5
       
    18 	>=sys-apps/dbus-1.4.20
       
    19 "
       
    20 RDEPEND="${DEPEND}
       
    21 	dev-qt/qtchooser
       
    22 "
       
    23 
       
    24 QT5_TARGET_SUBDIRS=(
       
    25 	src/dbus
       
    26 	src/tools/qdbusxml2cpp
       
    27 	src/tools/qdbuscpp2xml
       
    28 )
       
    29 
       
    30 QT5_GENTOO_CONFIG=(
       
    31 	:dbus
       
    32 	:dbus-linked:
       
    33 )
       
    34 
       
    35 QT5_GENTOO_PRIVATE_CONFIG=(
       
    36 	:dbus
       
    37 	:dbus-linked
       
    38 )
       
    39 
       
    40 src_configure() {
       
    41 	local myconf=(
       
    42 		-dbus-linked
       
    43 	)
       
    44 	qt5-build_src_configure
       
    45 }