x11-plugins/purple-facebook/purple-facebook-20210226.ebuild
changeset 25 50604c9253b9
parent 15 1ce7d66b189f
equal deleted inserted replaced
24:34adec9fb305 25:50604c9253b9
       
     1 # Copyright 1999-2020 Gentoo Authors
       
     2 # Distributed under the terms of the GNU General Public License v2
       
     3 
       
     4 EAPI=7
       
     5 
       
     6 inherit autotools git-r3 mercurial
       
     7 
       
     8 DESCRIPTION="Facebook protocol plugin for libpurple"
       
     9 HOMEPAGE="https://github.com/dequis/purple-facebook"
       
    10 
       
    11 LICENSE="GPL-2"
       
    12 SLOT="0"
       
    13 
       
    14 # purple-facebook snapshot
       
    15 EGIT_REPO_URI="https://github.com/dequis/purple-facebook.git"
       
    16 EGIT_COMMIT="1a6711f83d62e374ca2bed41fd4ca25b6bc654a2"
       
    17 # pidgin snapshot (hard dependency for purple-facebook, see file VERSION)
       
    18 EHG_REPO_URI="https://keep.imfreedom.org/pidgin/pidgin"
       
    19 EHG_REVISION="9ff9acf9fa14"
       
    20 EHG_CHECKOUT_DIR="${S}/.pidgin"
       
    21 
       
    22 PATCHES=( "${FILESDIR}/${P}-no-hg-while-compile.patch" )
       
    23 
       
    24 KEYWORDS="~amd64"
       
    25 IUSE=""
       
    26 
       
    27 RDEPEND="dev-libs/json-glib
       
    28 		 net-im/pidgin"
       
    29 DEPEND="dev-libs/json-glib" # Portage doesn't need to give us pidgin this time
       
    30 DOCS=( AUTHORS ChangeLog NEWS README VERSION )
       
    31 
       
    32 src_unpack() {
       
    33 	default
       
    34 	# This will check out pidgin in its working directory
       
    35 	mercurial_src_unpack || die
       
    36 	# This will check out purple-facebook in its working directory
       
    37 	git-r3_src_unpack || die
       
    38 }
       
    39 
       
    40 src_prepare() {
       
    41 	default
       
    42 	./autogen.sh
       
    43 }