equal
deleted
inserted
replaced
1 # Copyright 1999-2020 Gentoo Authors |
|
2 # Distributed under the terms of the GNU General Public License v2 |
|
3 |
|
4 EAPI=7 |
|
5 |
|
6 inherit autotools |
|
7 |
|
8 DESCRIPTION="Facebook protocol plugin for libpurple" |
|
9 HOMEPAGE="https://github.com/dequis/purple-facebook" |
|
10 |
|
11 LICENSE="GPL-2" |
|
12 SLOT="0" |
|
13 if test ${PV} == 9999; then |
|
14 inherit git-r3 |
|
15 SRC_URI="" |
|
16 EGIT_REPO_URI="https://github.com/dequis/purple-facebook.git" |
|
17 else |
|
18 MY_PV="0.9.6" |
|
19 S="${WORKDIR}/${PN}-${MY_PV}" |
|
20 SRC_URI="https://github.com/dequis/${PN}/releases/download/v${MY_PV}/${PN}-${MY_PV}.tar.gz -> ${P}.tar.gz" |
|
21 KEYWORDS="~amd64" |
|
22 fi |
|
23 IUSE="" |
|
24 |
|
25 RDEPEND="dev-libs/json-glib |
|
26 net-im/pidgin" |
|
27 DEPEND="${RDEPEND}" |
|
28 if test ${PV} == 9999; then |
|
29 # TODO: This is really bad as update.sh will later download libpurple |
|
30 BDEPEND="dev-vcs/mercurial" |
|
31 fi |
|
32 DOCS=( AUTHORS ChangeLog NEWS README VERSION ) |
|
33 |
|
34 src_unpack() { |
|
35 if test ${PV} == 9999; then |
|
36 git-r3_src_unpack |
|
37 else |
|
38 default |
|
39 fi |
|
40 } |
|
41 |
|
42 src_prepare() { |
|
43 default |
|
44 if test ${PV} == 9999; then |
|
45 ./autogen.sh |
|
46 else |
|
47 eautoreconf |
|
48 fi |
|
49 } |
|