equal
deleted
inserted
replaced
1 # Copyright 1999-2020 Gentoo Authors |
1 # Copyright 1999-2021 Gentoo Authors |
2 # Distributed under the terms of the GNU General Public License v2 |
2 # Distributed under the terms of the GNU General Public License v2 |
3 |
3 |
4 EAPI=7 |
4 EAPI=7 |
5 |
5 |
6 inherit fcaps meson |
6 inherit fcaps meson |
11 if [[ ${PV} == 9999 ]]; then |
11 if [[ ${PV} == 9999 ]]; then |
12 EGIT_REPO_URI="https://github.com/swaywm/${PN}.git" |
12 EGIT_REPO_URI="https://github.com/swaywm/${PN}.git" |
13 inherit git-r3 |
13 inherit git-r3 |
14 else |
14 else |
15 SRC_URI="https://github.com/swaywm/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz" |
15 SRC_URI="https://github.com/swaywm/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz" |
16 KEYWORDS="amd64 arm64 ~ppc64 x86" |
16 KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86" |
17 fi |
17 fi |
18 |
18 |
19 LICENSE="MIT" |
19 LICENSE="MIT" |
20 SLOT="0/13" |
20 SLOT="0/13" |
21 IUSE="elogind icccm seatd systemd x11-backend X" |
21 IUSE="elogind icccm seatd systemd x11-backend X" |
22 REQUIRED_USE="?? ( elogind systemd )" |
22 REQUIRED_USE="?? ( elogind systemd )" |
23 |
23 |
24 DEPEND=" |
24 DEPEND=" |
25 >=dev-libs/libinput-1.9.0:0= |
25 >=dev-libs/libinput-1.14.0:0= |
26 >=dev-libs/wayland-1.18.0 |
26 >=dev-libs/wayland-1.19.0 |
27 >=dev-libs/wayland-protocols-1.17.0 |
27 >=dev-libs/wayland-protocols-1.17.0 |
28 media-libs/mesa[egl,gles2,gbm] |
28 media-libs/mesa[egl,gles2,gbm] |
29 virtual/libudev |
29 virtual/libudev |
30 x11-libs/libdrm |
30 x11-libs/libdrm |
31 x11-libs/libxkbcommon |
31 x11-libs/libxkbcommon |
44 RDEPEND=" |
44 RDEPEND=" |
45 ${DEPEND} |
45 ${DEPEND} |
46 " |
46 " |
47 BDEPEND=" |
47 BDEPEND=" |
48 >=dev-libs/wayland-protocols-1.17 |
48 >=dev-libs/wayland-protocols-1.17 |
49 >=dev-util/meson-0.54.0 |
49 >=dev-util/meson-0.56.0 |
50 virtual/pkgconfig |
50 virtual/pkgconfig |
51 " |
51 " |
52 |
52 |
53 src_configure() { |
53 src_configure() { |
54 # xcb-util-errors is not on Gentoo Repository (and upstream seems inactive?) |
54 # xcb-util-errors is not on Gentoo Repository (and upstream seems inactive?) |