equal
deleted
inserted
replaced
|
1 # Copyright 1999-2021 Gentoo Authors |
|
2 # Distributed under the terms of the GNU General Public License v2 |
|
3 |
|
4 EAPI=7 |
|
5 |
|
6 inherit meson |
|
7 |
|
8 DESCRIPTION="xdg-desktop-portal backend for wlroots" |
|
9 HOMEPAGE="https://github.com/emersion/xdg-desktop-portal-wlr" |
|
10 |
|
11 if [[ ${PV} == 9999 ]]; then |
|
12 EGIT_REPO_URI="https://github.com/emersion/${PN}.git" |
|
13 inherit git-r3 |
|
14 else |
|
15 SRC_URI="https://github.com/emersion/${PN}/releases/download/v${PV}/${P}.tar.gz" |
|
16 KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86" |
|
17 fi |
|
18 |
|
19 LICENSE="MIT" |
|
20 SLOT="0/9999" |
|
21 IUSE="elogind systemd" |
|
22 REQUIRED_USE="?? ( elogind systemd )" |
|
23 |
|
24 DEPEND=" |
|
25 >=media-video/pipewire-0.3.2:= |
|
26 dev-libs/wayland |
|
27 >=dev-libs/wayland-protocols-1.14:= |
|
28 elogind? ( >=sys-auth/elogind-237 ) |
|
29 systemd? ( >=sys-apps/systemd-237 ) |
|
30 dev-libs/iniparser:0 |
|
31 " |
|
32 RDEPEND=" |
|
33 ${DEPEND} |
|
34 sys-apps/xdg-desktop-portal |
|
35 " |
|
36 BDEPEND=" |
|
37 >=media-video/pipewire-0.3.2:= |
|
38 >=dev-libs/wayland-protocols-1.14 |
|
39 >=dev-util/meson-0.50.0 |
|
40 virtual/pkgconfig |
|
41 " |
|
42 |
|
43 src_configure() { |
|
44 local emesonargs=( |
|
45 "-Dwerror=false" |
|
46 ) |
|
47 meson_src_configure |
|
48 } |