gui-apps/sway-marker/sway-marker-0.3.ebuild
changeset 50 e6ed7917d49a
equal deleted inserted replaced
49:0a8e8db8674d 50:e6ed7917d49a
       
     1 # Copyright 2025 Gentoo Authors
       
     2 # Distributed under the terms of the GNU General Public License v2
       
     3 
       
     4 EAPI=8
       
     5 
       
     6 CRATES="
       
     7 	anyhow@1.0.68
       
     8 	atk-sys@0.16.0
       
     9 	atk@0.16.0
       
    10 	autocfg@1.1.0
       
    11 	bitflags@1.3.2
       
    12 	cairo-rs@0.16.7
       
    13 	cairo-sys-rs@0.16.3
       
    14 	cc@1.0.78
       
    15 	cfg-expr@0.11.0
       
    16 	clap@4.0.32
       
    17 	clap_lex@0.3.0
       
    18 	errno-dragonfly@0.1.2
       
    19 	errno@0.2.8
       
    20 	field-offset@0.3.4
       
    21 	futures-channel@0.3.25
       
    22 	futures-core@0.3.25
       
    23 	futures-executor@0.3.25
       
    24 	futures-io@0.3.25
       
    25 	futures-macro@0.3.25
       
    26 	futures-task@0.3.25
       
    27 	futures-util@0.3.25
       
    28 	gdk-pixbuf-sys@0.16.3
       
    29 	gdk-pixbuf@0.16.7
       
    30 	gdk-sys@0.16.0
       
    31 	gdk@0.16.2
       
    32 	gio-sys@0.16.3
       
    33 	gio@0.16.7
       
    34 	glib-macros@0.16.3
       
    35 	glib-sys@0.16.3
       
    36 	glib@0.16.7
       
    37 	gobject-sys@0.16.3
       
    38 	gtk-layer-shell-sys@0.5.0
       
    39 	gtk-layer-shell@0.5.0
       
    40 	gtk-sys@0.16.0
       
    41 	gtk3-macros@0.16.0
       
    42 	gtk@0.16.2
       
    43 	heck@0.4.0
       
    44 	hermit-abi@0.2.6
       
    45 	io-lifetimes@1.0.3
       
    46 	is-terminal@0.4.2
       
    47 	itoa@1.0.5
       
    48 	libc@0.2.139
       
    49 	linux-raw-sys@0.1.4
       
    50 	memoffset@0.6.5
       
    51 	once_cell@1.17.0
       
    52 	os_str_bytes@6.4.1
       
    53 	pango-sys@0.16.3
       
    54 	pango@0.16.5
       
    55 	pest@2.5.3
       
    56 	pin-project-lite@0.2.9
       
    57 	pin-utils@0.1.0
       
    58 	pkg-config@0.3.26
       
    59 	proc-macro-crate@1.2.1
       
    60 	proc-macro-error-attr@1.0.4
       
    61 	proc-macro-error@1.0.4
       
    62 	proc-macro2@1.0.49
       
    63 	quote@1.0.23
       
    64 	rustc_version@0.3.3
       
    65 	rustix@0.36.6
       
    66 	ryu@1.0.12
       
    67 	semver-parser@0.10.2
       
    68 	semver@0.11.0
       
    69 	serde@1.0.152
       
    70 	serde_derive@1.0.152
       
    71 	serde_json@1.0.91
       
    72 	slab@0.4.7
       
    73 	smallvec@1.10.0
       
    74 	strsim@0.10.0
       
    75 	swayipc-types@1.3.0
       
    76 	swayipc@3.0.1
       
    77 	syn@1.0.107
       
    78 	system-deps@6.0.3
       
    79 	termcolor@1.1.3
       
    80 	thiserror-impl@1.0.38
       
    81 	thiserror@1.0.38
       
    82 	toml@0.5.10
       
    83 	ucd-trie@0.1.5
       
    84 	unicode-ident@1.0.6
       
    85 	version-compare@0.1.1
       
    86 	version_check@0.9.4
       
    87 	winapi-i686-pc-windows-gnu@0.4.0
       
    88 	winapi-util@0.1.5
       
    89 	winapi-x86_64-pc-windows-gnu@0.4.0
       
    90 	winapi@0.3.9
       
    91 	windows-sys@0.42.0
       
    92 	windows_aarch64_gnullvm@0.42.0
       
    93 	windows_aarch64_msvc@0.42.0
       
    94 	windows_i686_gnu@0.42.0
       
    95 	windows_i686_msvc@0.42.0
       
    96 	windows_x86_64_gnu@0.42.0
       
    97 	windows_x86_64_gnullvm@0.42.0
       
    98 	windows_x86_64_msvc@0.42.0
       
    99 "
       
   100 
       
   101 inherit cargo
       
   102 
       
   103 DESCRIPTION="Simple popup for using marks in Sway"
       
   104 HOMEPAGE="https://github.com/ilya-zlobintsev/sway-marker"
       
   105 SRC_URI="
       
   106 	https://github.com/ilya-zlobintsev/${PN}/archive/refs/tags/${PV}.tar.gz
       
   107 	${CARGO_CRATE_URIS}
       
   108 "
       
   109 
       
   110 LICENSE="GPL-3"
       
   111 # Dependent crate licenses
       
   112 LICENSE+="
       
   113 	MIT Unicode-DFS-2016
       
   114 	|| ( Apache-2.0 Boost-1.0 )
       
   115 "
       
   116 SLOT="0"
       
   117 KEYWORDS="~amd64"
       
   118 
       
   119 DEPEND="gui-libs/gtk-layer-shell"