www-apache/mod_wsgi/mod_wsgi-5.0.0-r1.ebuild
changeset 51 fd2f8bf4c8c6
equal deleted inserted replaced
50:e6ed7917d49a 51:fd2f8bf4c8c6
       
     1 # Copyright 1999-2024 Gentoo Authors
       
     2 # Distributed under the terms of the GNU General Public License v2
       
     3 
       
     4 EAPI=8
       
     5 
       
     6 PYTHON_COMPAT=( python3_{9..13} )
       
     7 PYTHON_REQ_USE="threads(+)"
       
     8 
       
     9 inherit apache-module python-single-r1
       
    10 
       
    11 DESCRIPTION="An Apache2 module for running Python WSGI applications"
       
    12 HOMEPAGE="https://github.com/GrahamDumpleton/mod_wsgi"
       
    13 SRC_URI="https://github.com/GrahamDumpleton/${PN}/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
       
    14 
       
    15 LICENSE="Apache-2.0"
       
    16 SLOT="0"
       
    17 KEYWORDS="amd64 ~arm ~arm64 ppc ~ppc64 x86"
       
    18 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
       
    19 
       
    20 RDEPEND="${PYTHON_DEPS}"
       
    21 
       
    22 APACHE2_MOD_CONF="70_${PN}"
       
    23 APACHE2_MOD_DEFINE="WSGI"
       
    24 APACHE2_MOD_FILE="${S}/src/server/.libs/${PN}.so"
       
    25 
       
    26 DOCFILES="README.rst"
       
    27 
       
    28 need_apache2
       
    29 
       
    30 pkg_setup() {
       
    31 	python-single-r1_pkg_setup
       
    32 
       
    33 	# Calling depend.apache_pkg_setup fails because we do not have
       
    34 	# "apache2" in IUSE but the function expects this in order to call
       
    35 	# _init_apache2_late which sets the APACHE_MODULESDIR variable.
       
    36 	_init_apache2
       
    37 	_init_apache2_late
       
    38 }
       
    39 
       
    40 src_configure() {
       
    41 	econf --with-apxs="${APXS}" --with-python="${PYTHON}"
       
    42 }
       
    43 
       
    44 src_compile() {
       
    45 	default
       
    46 }