gui-wm/hikari/hikari-9999.ebuild
changeset 30 5b3b4ac6d9f1
parent 0 22d142c795ec
child 31 84acc4672e6c
--- a/gui-wm/hikari/hikari-9999.ebuild	Thu Mar 25 16:07:41 2021 +0000
+++ b/gui-wm/hikari/hikari-9999.ebuild	Thu Mar 25 16:16:18 2021 +0000
@@ -1,9 +1,9 @@
-# Copyright 2019-2020 Gentoo Authors
+# Copyright 2019-2021 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
 
-inherit multiprocessing toolchain-funcs
+inherit toolchain-funcs
 
 DESCRIPTION="Wayland compositor inspired by CWM"
 HOMEPAGE="https://hikari.acmelabs.space/"
@@ -37,8 +37,10 @@
 	x11-misc/xkeyboard-config
 "
 
+# Needed in DEPEND only, as it needs to be right location, whatever that means
+DEPEND+=" dev-libs/wayland-protocols"
+
 BDEPEND="
-	dev-libs/wayland-protocols
 	virtual/pkgconfig
 	sys-devel/bmake
 "
@@ -58,7 +60,8 @@
 }
 
 src_compile() {
-	${MAKE} -j$(makeopts_jobs) VERSION="{PV}" \
+	emake \
+		VERSION="${PV}" \
 		CC="$(tc-getCC)" \
 		CFLAGS_EXTRA="${CFLAGS}" \
 		LDFLAGS_EXTRA="${LDFLAGS}" \
@@ -69,10 +72,16 @@
 		$(usex suid -DWITH_SUID "") \
 		$(usex virtual-io -DWITH_VIRTUAL_INPUT "") \
 		$(usex X -DWITH_XWAYLAND "") \
-		all || die
+		all
 }
 
 src_install() {
-	${MAKE} DESTDIR="${D}" PREFIX=/usr ETC_PREFIX=/ $(usex suid -DWITH_SUID "") install || die
+	emake \
+		DESTDIR="${D}" \
+		PREFIX=/usr \
+		ETC_PREFIX=/ \
+		$(usex suid -DWITH_SUID "") \
+		install
+
 	doman share/man/man1/hikari.1
 }