x11-plugins/purple-facebook/purple-facebook-9999.ebuild
changeset 8 d9ca0ab77018
child 9 c53c250c2080
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/x11-plugins/purple-facebook/purple-facebook-9999.ebuild	Thu Jan 21 11:03:17 2021 +0000
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Facebook protocol plugin for libpurple"
+HOMEPAGE="https://github.com/dequis/purple-facebook"
+
+LICENSE="GPL-2"
+SLOT="0"
+if test ${PV} == 9999; then
+	SRC_URI=""
+	EGIT_REPO_URI="https://github.com/dequis/purple-facebook.git"
+	KEYWORDS=""
+else
+	MY_PV="0.9.6"
+	S="${WORKDIR}/${PN}-${MY_PV}"
+	SRC_URI="https://github.com/dequis/${PN}/releases/download/v${MY_PV}/${PN}-${MY_PV}.tar.gz -> ${P}.tar.gz"
+	KEYWORDS="~amd64"
+fi
+IUSE=""
+
+RDEPEND="dev-libs/json-glib
+	 net-im/pidgin"
+DEPEND="${RDEPEND}"
+DOCS=( AUTHORS ChangeLog NEWS README VERSION )
+
+src_unpack() {
+	if test ${PV} == 9999; then
+		git-r3_src_unpack
+	else
+		default
+	fi
+}
+
+src_prepare() {
+	default
+	eautoreconf
+}