gui-apps/wev/wev-1.0.0.ebuild
author gabriel
Sat, 03 May 2025 11:14:57 +0100
changeset 52 a005dcda4775
parent 40 10be8f1bcd64
permissions -rw-r--r--
Attempt to make clang 15 compatible with python 3.13

# Copyright 2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

DESCRIPTION="Wayland event viewer"
HOMEPAGE="https://git.sr.ht/~sircmpwn/wev"
SRC_URI="https://git.sr.ht/~sircmpwn/${PN}/archive/${PV}.tar.gz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64"
IUSE=""

DEPEND="
	dev-libs/wayland
	x11-libs/libxkbcommon"
RDEPEND="${DEPEND}"
BDEPEND="app-text/scdoc"

src_install() {
	export PREFIX="${EPREFIX}/usr" # We install in the same place as xev, but this is optional
	default
}