# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit autotools git-r3 mercurial
DESCRIPTION="Facebook protocol plugin for libpurple"
HOMEPAGE="https://github.com/dequis/purple-facebook"
LICENSE="GPL-2"
SLOT="0"
# purple-facebook snapshot
EGIT_REPO_URI="https://github.com/dequis/purple-facebook.git"
EGIT_COMMIT="1a6711f83d62e374ca2bed41fd4ca25b6bc654a2"
# pidgin snapshot (hard dependency for purple-facebook, see file VERSION)
EHG_REPO_URI="https://keep.imfreedom.org/pidgin/pidgin"
EHG_REVISION="9ff9acf9fa14"
EHG_CHECKOUT_DIR="${S}/.pidgin"
PATCHES=( "${FILESDIR}/${P}-no-hg-while-compile.patch" )
KEYWORDS="~amd64"
IUSE=""
RDEPEND="dev-libs/json-glib
net-im/pidgin"
DEPEND="dev-libs/json-glib" # Portage doesn't need to give us pidgin this time
DOCS=( AUTHORS ChangeLog NEWS README VERSION )
src_unpack() {
default
# This will check out pidgin in its working directory
mercurial_src_unpack || die
# This will check out purple-facebook in its working directory
git-r3_src_unpack || die
}
src_prepare() {
default
./autogen.sh
}