x11-plugins/purple-facebook/purple-facebook-9999.ebuild
author gabriel
Thu, 21 Jan 2021 11:59:16 +0000
changeset 11 b3b4f824fd57
parent 10 15cccc9297db
child 12 015e732283f7
permissions -rw-r--r--
Added mercurial dependency to checkout libpurple, added call to autogen.sh

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit autotools

DESCRIPTION="Facebook protocol plugin for libpurple"
HOMEPAGE="https://github.com/dequis/purple-facebook"

LICENSE="GPL-2"
SLOT="0"
if test ${PV} == 9999; then
	inherit git-r3
	SRC_URI=""
	EGIT_REPO_URI="https://github.com/dequis/purple-facebook.git"
else
	MY_PV="0.9.6"
	S="${WORKDIR}/${PN}-${MY_PV}"
	SRC_URI="https://github.com/dequis/${PN}/releases/download/v${MY_PV}/${PN}-${MY_PV}.tar.gz -> ${P}.tar.gz"
	KEYWORDS="~amd64"
fi
IUSE=""

RDEPEND="dev-libs/json-glib
	 net-im/pidgin"
DEPEND="${RDEPEND}"
if test ${PV} == 9999; then
	# TODO: This is really bad as update.sh will later download libpurple
	BDEPEND="dev-vcs/mercuarial"
fi
DOCS=( AUTHORS ChangeLog NEWS README VERSION )

src_unpack() {
	if test ${PV} == 9999; then
		git-r3_src_unpack
	else
		default
	fi
}

src_prepare() {
	if test ${PV} == 9999; then
		./autogen.sh
	fi
	default
	eautoreconf
}