gui-apps/sway-marker/sway-marker-0.3.ebuild
author gabriel
Mon, 28 Apr 2025 11:24:48 +0100
changeset 50 e6ed7917d49a
permissions -rw-r--r--
Removed wayland-info, added sway-marker

# Copyright 2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

CRATES="
	anyhow@1.0.68
	atk-sys@0.16.0
	atk@0.16.0
	autocfg@1.1.0
	bitflags@1.3.2
	cairo-rs@0.16.7
	cairo-sys-rs@0.16.3
	cc@1.0.78
	cfg-expr@0.11.0
	clap@4.0.32
	clap_lex@0.3.0
	errno-dragonfly@0.1.2
	errno@0.2.8
	field-offset@0.3.4
	futures-channel@0.3.25
	futures-core@0.3.25
	futures-executor@0.3.25
	futures-io@0.3.25
	futures-macro@0.3.25
	futures-task@0.3.25
	futures-util@0.3.25
	gdk-pixbuf-sys@0.16.3
	gdk-pixbuf@0.16.7
	gdk-sys@0.16.0
	gdk@0.16.2
	gio-sys@0.16.3
	gio@0.16.7
	glib-macros@0.16.3
	glib-sys@0.16.3
	glib@0.16.7
	gobject-sys@0.16.3
	gtk-layer-shell-sys@0.5.0
	gtk-layer-shell@0.5.0
	gtk-sys@0.16.0
	gtk3-macros@0.16.0
	gtk@0.16.2
	heck@0.4.0
	hermit-abi@0.2.6
	io-lifetimes@1.0.3
	is-terminal@0.4.2
	itoa@1.0.5
	libc@0.2.139
	linux-raw-sys@0.1.4
	memoffset@0.6.5
	once_cell@1.17.0
	os_str_bytes@6.4.1
	pango-sys@0.16.3
	pango@0.16.5
	pest@2.5.3
	pin-project-lite@0.2.9
	pin-utils@0.1.0
	pkg-config@0.3.26
	proc-macro-crate@1.2.1
	proc-macro-error-attr@1.0.4
	proc-macro-error@1.0.4
	proc-macro2@1.0.49
	quote@1.0.23
	rustc_version@0.3.3
	rustix@0.36.6
	ryu@1.0.12
	semver-parser@0.10.2
	semver@0.11.0
	serde@1.0.152
	serde_derive@1.0.152
	serde_json@1.0.91
	slab@0.4.7
	smallvec@1.10.0
	strsim@0.10.0
	swayipc-types@1.3.0
	swayipc@3.0.1
	syn@1.0.107
	system-deps@6.0.3
	termcolor@1.1.3
	thiserror-impl@1.0.38
	thiserror@1.0.38
	toml@0.5.10
	ucd-trie@0.1.5
	unicode-ident@1.0.6
	version-compare@0.1.1
	version_check@0.9.4
	winapi-i686-pc-windows-gnu@0.4.0
	winapi-util@0.1.5
	winapi-x86_64-pc-windows-gnu@0.4.0
	winapi@0.3.9
	windows-sys@0.42.0
	windows_aarch64_gnullvm@0.42.0
	windows_aarch64_msvc@0.42.0
	windows_i686_gnu@0.42.0
	windows_i686_msvc@0.42.0
	windows_x86_64_gnu@0.42.0
	windows_x86_64_gnullvm@0.42.0
	windows_x86_64_msvc@0.42.0
"

inherit cargo

DESCRIPTION="Simple popup for using marks in Sway"
HOMEPAGE="https://github.com/ilya-zlobintsev/sway-marker"
SRC_URI="
	https://github.com/ilya-zlobintsev/${PN}/archive/refs/tags/${PV}.tar.gz
	${CARGO_CRATE_URIS}
"

LICENSE="GPL-3"
# Dependent crate licenses
LICENSE+="
	MIT Unicode-DFS-2016
	|| ( Apache-2.0 Boost-1.0 )
"
SLOT="0"
KEYWORDS="~amd64"

DEPEND="gui-libs/gtk-layer-shell"